PHP5にPEARをインストール?

先ほどphp5-pearが入らないと書きましたがインストールする方法を投稿しておられる方がおられましたのでやってみました。(2007年11月23日現在の結果:失敗)
PHP5.1-pearを入れる

<code>
$ su
# vim /etc/apt/sources.list
</code>

として「/etc/apt/sources.list」に以下の記述を追加します。

<code>
deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all
</code>
<code>
# apt-get update
# apt-get install php5-pear
</code>

あれ?

パッケージリストを読み込んでいます… 完了
依存関係ツリーを作成しています… 完了
パッケージ php5-pear はデータベースには存在しますが、利用できません。
おそらく、そのパッケージが見つからないか、もう古くなっているか、
あるいは別のソースからのみしか利用できないという状況が考えられます
E: パッケージ php5-pear にはインストール候補がありません

php-pearもやってみました。

<code>
# aptitude install php-pear
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています... 完了
拡張状態情報を読み込んでいます
パッケージの状態を初期化しています... 完了
タスクの記述を読み込んでいます... 完了
タグのデータベースを構築しています... 完了
以下のパッケージは依存関係が壊れています:
  libapache2-mod-php5 php5-cli php5-gd php5-mysql
以下のパッケージが一時固定されています:
  libmysqlclient15off mysql-client-5.0 mysql-common mysql-server mysql-server-5.0 php4-common php4-dev php4-pear php5 php5-dev
以下のパッケージが更新されます:
  php-pear php5-common
更新: 2 個、新規インストール: 0 個、削除: 0 個、保留: 14 個。
566kB のアーカイブを取得する必要があります。展開後に 549kB のディスク領域が新たに消費されます。
以下のパッケージには満たされていない依存関係があります:
  php5-gd: 依存: php5-common (= 5.2.0-8+etch7) しかし 5.2.5-0.dotdeb.1 はインストール予定です。
  php5-mysql: 依存: php5-common (= 5.2.0-8+etch7) しかし 5.2.5-0.dotdeb.1 はインストール予定です。
  php5-cli: 依存: php5-common (= 5.2.0-8+etch7) しかし 5.2.5-0.dotdeb.1 はインストール予定です。
  libapache2-mod-php5: 依存: php5-common (= 5.2.0-8+etch7) しかし 5.2.5-0.dotdeb.1 はインストール予定です。
Resolving dependencies...
以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを更新します:
libapache2-mod-php5 [5.2.0-8+etch7 (stable, now) -&gt; 5.2.5-0.dotdeb.1 ()]
php5-cli [5.2.0-8+etch7 (stable, now) -&gt; 5.2.5-0.dotdeb.1 ()]
php5-gd [5.2.0-8+etch7 (stable, now) -&gt; 5.2.5-0.dotdeb.1 ()]
php5-mysql [5.2.0-8+etch7 (stable, now) -&gt; 5.2.5-0.dotdeb.1 ()]

スコアは -150 です

この解決方法を受け入れますか? [Y/n/q/?]
</code>

moguraも動いているのでこれはやめておきます。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

*

question razz sad evil exclaim smile redface biggrin surprised eek confused cool lol mad twisted rolleyes wink idea arrow neutral cry mrgreen

次のHTML タグと属性が使えます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>